Supported Platforms HPE Vertica Analytic Database. Software Version: 7.2.x

Full text

(1)

Supported Platforms

HPE Vertica Analytic Database

Software Version: 7.2.x

(2)

Legal Notices

Warranty

The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HPE shall not be liable for technical or editorial errors or omissions contained herein. The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HPE required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Copyright Notice

© Copyright 2006 - 2016 Hewlett Packard Enterprise Development LP

Trademark Notices

Adobe™ is a trademark of Adobe Systems Incorporated.

Apache® Hadoop® and Hadoop are either registered trademarks or trademarks of the Apache Software Foundation in the United States and/or other countries.

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation. UNIX® is a registered trademark of The Open Group.

(3)

Contents

Vertica Server and Vertica Management Console 5

Supported Operating Systems and Operating System Versions 5 Red Hat Enterprise Linux 5

CentOS 6

SUSE Linux Enterprise Server 6 Oracle Enterprise Linux 6 6

Debian Linux 6

Ubuntu 6

Supported Browsers for Vertica Management Console 7 Vertica Server and Management Console Compatibility 7

Vertica 7.2.x Client Drivers 8

ADO.NET Driver 8

JDBC Driver 9

ODBC Driver 10

Vertica Analytic Database Driver/Server Compatibility 12

vsql Client 12

Perl and Python Requirements 14

Perl 14 Python 14 Vertica SDKs 15 C++ SDK 15 Java SDK 15 R Language Pack 15

Vertica Integrations for Hadoop 16

Packs, Plug-Ins, and Connectors for Vertica Client Machines 18

(4)

Vertica Integration for Apache Kafka 22

End of Support Notices 23

(5)

Vertica Server and Vertica

Management Console

Supported Operating Systems and

Operating System Versions

Hewlett Packard Enterprise supports Vertica Analytic Database 7.2.x running on the following 64-bit operating systems and versions on x86_x64 architecture.

Important:This document reflects what has been tested with Vertica Analytic Database 7.2.x. Be aware that operating system vendors and communities release updates and patches for all versions of their operating systems on their own

schedules. Such updates to these operating systems may or may not coincide with the release schedule for Vertica. While other versions of the operating systems listed may have been successfully deployed by customers in their environments, stability and performance of these configurations may vary. If you choose to run Vertica on an operating system version not listed in this document and experience an issue, the Vertica Support team may ask you to reproduce the issue using one of the

configurations described in this document to aid in troubleshooting. Depending on the details of the case, the Support team may also ask you to enter a support ticket with your operating system vendor.

Red Hat Enterprise Linux

l All versions starting at 6.0 up to and including 6.7 * l Version 7.0

*Hewlett Packard Enterprise is phasing out support for HPE Vertica on some of these operating systems. SeeEnd of Support Noticesfor more information.

Important:You cannot perform an in-place upgrade of your current Vertica Analytic Database from Red Hat Enterprise Linux 6.0 — 6.7 to Red Hat Enterprise Linux 7.0. For information how to upgrade to Red Hat Enterprise Linux 7.0, see theMigration Guide for Red Hat 7/CentOS 7.

(6)

CentOS

l All versions starting at 6.0 up to and including 6.7 * l Version 7.0

*Hewlett Packard Enterprise is phasing out support for HPE Vertica on some of these operating systems. SeeEnd of Support Noticesfor more information.

Important:You cannot perform an in-place upgrade of your current Vertica Analytic Database from CentOS 6.0 — 6.7 to CentOS 7.0. For information on how to upgrade to CentOS 7.0, see theMigration Guide for Red Hat 7/CentOS 7.

SUSE Linux Enterprise Server

All versions starting at 11.0 up to and including 11.0 SP3. *

*Hewlett Packard Enterprise is phasing out support for HPE Vertica on some of these operating systems. SeeEnd of Support Noticesfor more information.

Oracle Enterprise Linux 6

Red Hat Compatible Kernel only - Vertica is not supported on the unbreakable kernel (kernels with a uel suffix).

Debian Linux

All versions starting at 7.0 up to and including 7.7. *

*Hewlett Packard Enterprise is phasing out support for HPE Vertica on some of these operating systems. SeeEnd of Support Noticesfor more information.

Ubuntu

l Version 12.04 LTS l Version 14.04 LTS

When there are multiple minor versions supported for a major operating system release, Hewlett Packard Enterprise recommends that you run Vertica on the latest minor version listed in the supported versions list. For example, if you run Vertica on the Debian Linux 7.0 major release, Hewlett Packard Enterprise recommends you use version 7.7.

However, for both Red Hat Enterprise Linux and CentOS, Hewlett Packard Enterprise recommends using any of the following versions for the 6.0 major release: 6.5, 6.6, or 6.7

(7)

Supported File Systems

Vertica Analytic Database Enterprise Edition has been tested on all supported Linux platforms running ext3 or ext4 file systems. For the Vertica Analytic Database I/O profile, the ext4 file system is considerably faster than ext3.

While other file systems have been successfully deployed by some customers, Vertica Analytic Database cannot guarantee performance or stability of the product on these file systems. In certain support situations, you may be asked to migrate off of these

unsupported file systems to help you troubleshoot or fix an issue. In particular, several file corruption issues have been linked to the use of XFS with Vertica; Hewlett Packard Enterprise strongly recommends not using it in production.

Important:Vertica Analytic Database 7.2.x does not support Linux Logical Volume Manager (LVM).

Supported Browsers for Vertica

Management Console

Vertica Analytic Database 7.2.x Management Console is supported on the following web browsers:

l Internet Explorer 10 and later l Firefox 31 and later

l Google Chrome 38 and later

Vertica Server and Management Console

Compatibility

Each version of Vertica Analytic Database Management Console is compatible only with the matching version of the Vertica Analytic Database server. For example, the Vertica Analytic Database 7.2 server is supported with Vertica Analytic Database 7.2 Management Console only.

(8)

Vertica 7.2.x Client Drivers

Vertica provides JDBC, ODBC, OLE DB, and ADO.NET client drivers. You can choose to download:

l Linux and UNIX-like platforms — ODBC client driver, client RPM, and vsql client.

SeeInstalling the Client Drivers on Linux and UNIX-Like Platforms.

l Windows platforms — ODBC, ADO.NET, and OLE DB client drivers, the vsql client,

the Microsoft Connectivity Pack, and the Visual Studio plug-in. SeeInstalling the Client Drivers and Tools on Windows.

l Mac OS X platforms — ODBC client driver and vsql client. SeeInstalling the Client Drivers on Mac OS X.

l The cross-platform JDBC client driver.jarfile available for installation on all

platforms.

See Vertica Driver/Server compatibility to see which server versions are compatible with Vertica 6.1.x drivers.

ADO.NET Driver

The ADO.NET driver is supported on the following platforms:

Platform Processor Supported Versions

.NET Requirements

Microsoft Windows x86 (32-bit) Windows 7 Windows 8 Windows 10

Microsoft .NET Framework 3.5 SP1 or later

Microsoft Windows x64 (64-bit) Windows 7 Windows 8 Windows 10 Microsoft Windows Server x86 (32-bit) 2008 * 2008 R2 * Microsoft Windows Server x64 (64-bit) 2008 * 2008 R2 *

(9)

2012 2012 R2

*Hewlett Packard Enterprise is phasing out support for HPEVertica on some of these operating systems. SeeEnd of Support Noticesfor more information.

JDBC Driver

All JDBC drivers are supported on any Java 5-compliant platform. (Java 5 is the minimum.)

(10)

ODBC Driver

Vertica Analytic Database provides both 32-bit and 64-bit ODBC drivers. Vertica 7.2.x ODBC drivers are supported on the following platforms:

Platform Processor Supported Versions

Driver Manager

Microsoft Windows x86 (32-bit) Windows 7 Windows 8 Windows 10

Microsoft ODBC MDAC 2.8

Microsoft Windows x64 (64-bit) Windows 7 Windows 8 Windows 10 Microsoft Windows Server x86 (32-bit) 2008 * 2008 R2 * Microsoft Windows Server x64 (64-bit) 2008 * 2008 R2 * 2012 2012 R2 Red Hat Enterprise

Linux x86_64 6 and 7 iODBC 3.52.6 or later unixODBC 2.3.0 or later DataDirect 5.3 and 6.1 or later SUSE Linux Enterprise x86_64 11 Oracle Enterprise Linux (Red Hat Compatible Kernel only) x86_64 6 CentOS x86_64 6 and 7 Ubuntu x86_64 12.04 LTS 14.04 LTS

(11)

Platform Processor Supported Versions

Driver Manager

AIX PowerPC 5.3 and 6.1 iODBC 3.52.6 or later

unixODBC 2.3.0 or later

DataDirect 5.3 and 6.1 or later

HP-UX IA-64 11i V3 iODBC 3.52.6 or

later unixODBC 2.3.0 or later DataDirect 5.3 and 6.1 or later Solaris SPARC 10 Mac OS X x86_64 10.7, 10.8, and 10.9 *

*Hewlett Packard Enterprise is phasing out support for HPEVertica on some of these operating systems. SeeEnd of Support Noticesfor more information.

(12)

Vertica Analytic Database Driver/Server

Compatibility

The following table indicates the Vertica Analytic Database driver versions that are supported by different Vertica Analytic Database server versions.

Note:SHA password security is supported on client driver and server versions 7.1.x and later.

Client Driver Version Compatible Server Versions

6.1.x 6.1.x, 7.0.x, 7.1.x, 7.2.x 7.0.x 7.0.x, 7.1.x, 7.2.x 7.1.x 7.1.x, 7.2.x

7.2.x 7.2.x

vsql Client

The Vertica vsql client is included in all client packages; it is not available for download separately. The vsql client is supported on the following platforms:

Operating System Processor

Microsoft Windows

l Windows 2008 & 2008 R2, all variants l Windows 2012 & 2012 R2, all variants l Windows 7, all variants

l Windows 8.*, all variants l Windows 10

x86, x64

Red Hat Enterprise Linux 6 x86, x64

Red Hat Enterprise Linux 7 x86, x64

(13)

Operating System Processor

SUSE Linux Enterprise 11 x86, x64

Oracle Enterprise Linux 6 (Red Hat Compatible Kernel only) x86, x64

CentOS 6 x86, x64

CentOS 7 x86, x64

Ubuntu 12.04LTS x86, x64

Solaris 10 x86, x64, SPARC

AIX 5.3, 6.1 PowerPC

HPUX 11i V3 IA32, IA64

Mac OS X 10.7, 10.8, 10.9 x86, x64

(14)

Perl and Python Requirements

You can use Vertica's ODBC driver to connect applications written in Perl or Python to the Vertica Analytic Database.

Perl

To use Perl with Vertica, you must install the Perl driver modules (DBI and DBD::ODBC) and a Vertica ODBC driver on the machine where Perl is installed. The following table lists the Perl versions supported with Vertica 7.2.x.

Perl Version Perl Driver Modules ODBC Requirements

l 5.8 l 5.10

l DBI driver version 1.609 l DBD::ODBC version

1.22

SeeVertica 7.2.x Client Drivers.

Python

To use Python with Vertica, you must install the Vertica Python Client or the pyodbc module and a Vertica ODBC driver on the machine where Python is installed. The following table lists the Python versions supported with Vertica 7.2.x:

Python Version

Python Driver Module ODBC Requirements

2.4.6 pyodbc 2.1.6 SeeVertica 7.2.x Client Drivers. 2.7.x Vertica Python Client

(Linux only) 2.7.3 pyodbc 3.0.6 3.3.4 pyodbc 3.0.7

(15)

Vertica SDKs

This section details software requirements for running User Defined Extensions (UDxs) developed using the Vertica SDKs.

C++ SDK

The Vertica cluster does not have any special requirements for running UDXs written in C++.

Java SDK

Your Vertica cluster must have a Java runtime installed to run UDxs developed using the Vertica Java SDK. HPE has tested the following Java Runtime Environments (JREs) with this version of the Vertica Java SDK:

l Oracle Java Platform Standard Edition 6 (version number 1.6) l Oracle Java Platform Standard Edition 7 (version number 1.7) l OpenJDK 6 (version number 1.6)

l OpenJDK 7 (version number 1.7)

R Language Pack

The Vertica R Language Pack provides version 3.0.0 of the R runtime and associated libraries for interfacing with Vertica. You install the R Language Pack on the Vertica server.

(16)

Vertica Integrations for Hadoop

Vertica 7.2.x is supported with these Hadoop distributions:

Distribution Support in Vertica 7.2.0 to 7.7.1 Support in Vertica 7.2.2 Support in Vertica 7.2.3 Cloudera (CDH) l 5.2 l 5.3 l 5.4 l 5.5 l 5.3 l 5.4 l 5.5 l 5.5 * l 5.6 HortonWorks Data Platform (HDP) l 2.2 l 2.3 l 2.2 l 2.3 l 2.3 l 2.4 MapR l 3.1.1 l 4.0 l 3.1.1 l 4.0 l 3.1.1 * l 4.0 *

*Hewlett Packard Enterprise is phasing out support for HPE Vertica on these versions of Hadoop. SeeEnd of Support Noticesfor more information.

Vertica Connector for Hadoop MapReduce *

HP provides a module specific to Hadoop for Vertica client machines.

Vertica provides a Connector for Apache Hadoop 2.0.0. The table below details supported software versions.

Description Vertica Connector for Apache Hadoop MapReduce for Hadoop 2.0.0

Apache Hadoop and Pig Combinations

Apache Hadoop 2.0.0 and Pig 0.10.0

Cloudera Distribution Versions

Cloudera Distribution Including Apache Hadoop (CDH) 4

*Hewlett Packard Enterprise is phasing out support for the Vertica Connector for Hadoop MapReduce in future versions of HPE Vertica. Vertica 7.2.x is the last

(17)

major/minor version on which the Vertica Connector for Hadoop MapReduce will be supported. SeeEnd of Support Noticesfor more information. However. the Vertica Connector for Hadoop MapReduce has been open-sourced and the source code is available onGitHub.

(18)

Packs, Plug-Ins, and Connectors for

Vertica Client Machines

HPE provides the following optional module for Vertica client machines.

Informatica PowerCenter Plug-In

The Vertica plug-in for Informatica PowerCenter is supported on the following platforms:

Plug-in Version

Operating System Informatica

PowerCenter Versions Vertica Versions 7.x Microsoft Windows l Windows 2003 & 2003 R2 all variants l Windows 2008 & 2008 R2 all variants

l Windows 7 all variants

Red Hat Enterprise Linux 5 (32 and 64 bit) Solaris AIX HP-UX 9.x 6.x (limited functionality) 7.x (all enhancements)

(19)

Vertica on Amazon Web Services

HPE provides a preconfigured AMI for users who want to run Vertica Analytic Database on Amazon Web Services (AWS). This HP-supplied AMI allows users to configure their own storage and has been configured for and tested on AWS. This AMI is the officially supported version of Vertica Analytic Database for AWS.

Note that HPE develops AMIs for Vertica on a slightly different schedule than our product release schedule. Therefore, AMIs will be available for Vertica releases sometime following the initial release of Vertica software.

(20)

Vertica in a Virtualized Environment

Vertica runs in the following virtualization environment:

Important:Vertica does not support suspending a virtual machine while Vertica is running on it.

Host

l VMware version 5.5

l The number of virtual machines per host did not exceed the number of physical

processors

l CPU frequency scaling turned off at the host level and for each virtual machine l VMware parameters for hugepages set at version. 5.5 defaults

Input/Output

l Measured byvioperfconcurrently on all Vertica nodes When running vioperf, provide

the–duration=2min option and start on all nodes concurrently

l 25 megabytes per second per core of write l 20+20 megabytes per second per core of rewrite l 40 megabytes per second per core of read l 150 seeks per second of latency (SkipRead) l Thick provisioned disk, or pass-through-storage

Network

l Dedicated 10G NIC for each Virtual Machine

l No oversubscription at the switch layer, verified withvnetperf

(21)

Processor

l Architecture of Sandy Bridge (HP Gen8 or higher) l 8 or more virtual cores per virtual machine

l No oversubscription

l vcpuperftime of no more than 12 seconds ( ~= 2.2 GHz clock speed)

Memory

l Pre-allocate and reserve memory for the VM l 4G per virtual core of the virtual machines

HP has tested the configuration above. While other virtualization configurations may have been successfully deployed by customers in development environments,

performance of these configurations may vary. If you choose to run Vertica on a different virtualization configuration and experience an issue, the Vertica Support team may ask you to reproduce the issue using the configuration described above, or in a bare-metal environment, to aid in troubleshooting. Depending on the details of the case, the

Support team may also ask you to enter a support ticket with your virtualization vendor.

(22)

Vertica Integration for Apache Kafka

You can use Vertica with the Apache Kafka message broker. Vertica supports the following Kafka distributions:

Apache Kafka Versions Vertica Versions

0.8.x 7.2 and later

0.9.0 7.2 SP2

For more information on Kafka integration, refer toHow Vertica and Apache Kafka Work Together.

(23)

End of Support Notices

HPE is withdrawing support for Vertica on the following operating systems and Apache Hadoop distributions in the next major or minor release of HPE Vertica.

Vertica 7.2.x is the last major/minor version on which the following operating systems and Hadoop distributions will be supported. Note that Vertica 7.2.x service packs will continue to be released for these operating systems and distributions. However, they will not be supported on any subsequent major or minor release after Vertica 7.2.x.

Operating Systems:

HPE Vertica Server:

l Red Hat Enterprise Linux (RHEL) 6.0 to 6.4 l CentOS 6.0 to 6.4

l SUSE Linux Enterprise Server 11.0 to 11 SP2 l Debian Linux 7.0 to 7.5

HPE Client Drivers: (Driver - OS Version)

l ADO.NET - Microsoft Windows Server 2008 l ODBC - Microsoft Windows Server 2008 l OLEDB - Microsoft Windows Server 2008 l MAC OS X - 10.7, 10.8

Apache Hadoop Distributions:

l Cloudera CDH 5.2, 5.3, 5.4, 5.5 l Hortonworks HDP 2.2

l MapR 3.1.1, 4.0

(24)

Vertica Connector for Hadoop MapReduce:

l No support on any version after Vertica version 7.2.3. However, the source code is

available onGitHub.

(25)

Send Documentation Feedback

If you have comments about this document, you cancontact the documentation teamby email. If an email client is configured on this system, click the link above and an email window opens with the following information in the subject line:

Feedback on Supported Platforms (Vertica Analytic Database 7.2.x) Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and send your feedback to vertica-docfeedback@hpe.com.

Figure

Updating...

References

  1. GitHub.
Related subjects :