• No results found

Splunk 4.0.9 Installation Guide

N/A
N/A
Protected

Academic year: 2021

Share "Splunk 4.0.9 Installation Guide"

Copied!
73
0
0

Loading.... (view fulltext now)

Full text

(1)

Splunk Installation Manual

Version: 4.0.9

Generated: 5/10/2010 03:24 am

(2)

Table of Contents

Welcome to the Splunk Installation Manual...1

What's in the Installation Manual...1

System requirements...1

Components of a Splunk deployment...3

Splunk's architecture and what gets installed...4

About Splunk licenses...5

More about Splunk Free...9

Before you install...10

Step by step installation procedures...11

Choose your platform...11

Install on Windows...11

Install on Windows via the commandline...15

Install on Linux...20

Install on Solaris...22

Install on Mac OS...25

Install on FreeBSD...27

Install on AIX...29

Install on HP-UX...31

Install a license...32

Start Splunk for the first time...35

Start Splunk for the first time...35

Migrate from 3.4.x or earlier...37

What to expect when migrating to 4.0...37

Migrate on UNIX...43

Migrate on Windows...45

Steps for manual migration to Splunk 4.x...47

Upgrade from 4.0 or later...52

Upgrade Splunk on Windows...52

Upgrade Splunk on Linux, Solaris, FreeBSD, HP-UX, AIX, and MacOS...53

Other tasks...55

Run Splunk as a different or non-root user...55

Uninstall Splunk...56

Correcting the user selected during Windows installation...58

Configure a standalone 3.4.x deployment server...59

What comes next?...61

Ready to start using Splunk?...61

Estimating your storage requirements...61

(3)

Table of Contents

Reference...70 PGP Public Key...70 File manifest...70

(4)

Welcome to the Splunk Installation Manual

What's in the Installation Manual

What's in the Installation Manual

Use this guide to find system requirements, licensing information, and procedures for installing or migrating Splunk.

Find what you need

You can use the table of contents to the left of this panel, or simply search for what you want in the search box in the upper right.

If you're interested in more specific scenarios and best practices, you can visit the Splunk Community Wiki to see how other users Splunk IT.

Make a PDF

If you'd like a PDF of any version of this manual, click the pdf version link above the table of

contents bar on the left side of this page. A PDF version of the manual is generated on the fly for you, and you can save it or print it out to read later.

System requirements

System requirements

Before you download and install the Splunk software, read the following sections for the supported system requirements. If you have ideas or requests for new features to add to future releases, email Splunk Support. Also, you can follow our Product Roadmap.

Refer to the download page for the latest version to download. Check the release notes for details on known and resolved issues.

For a discussion of hardware planning for deployment, check out the topic on capacity planning in this manual.

Supported OSes

Splunk is supported on the following platforms. Solaris 9, 10 (x86, SPARC)

Linux Kernel vers 2.6.x and above (x86: 32 and 64-bit) •

FreeBSD 6.1 and 6.2 (x86: 32 and 64-bit) •

Windows 2003 (x86: 64-bit, supported but not recommended on 32-bit) •

Windows 2008 (x86: 64-bit, supported but not recommended on 32-bit) •

WindowsXP (x86: 32-bit) •

Vista (x86: 32-bit, 64-bit) •

(5)

MacOSX 10.5 and 10.6 (32-bit & 64bit in one download, 10.6 is only supported in 32-bit

mode)

AIX 5.2 and 5.3 •

HP-UX 11iv2 (11.22) and 11iv3 (11.31) (PA-RISC or Itanium) •

FreeBSD 7.x

To run Splunk 4.x on 32-bit FreeBSD 7.x, install the compat6x libraries. Splunk Support will supply "best effort" support for users running on FreeBSD 7.x. For more information, refer to this Community wiki topic.

Creating and editing configuration files on non-UTF-8 OSes

Splunk expects configuration files to be in ASCII/UTF-8. If you are editing or creating a configuration file on an OS that is non-UTF-8, you must ensure that the editor you are using is configured to save in ASCII/UTF-8.

Supported browsers

Firefox 2 and 3.0.x •

Firefox 3.5 (with Splunk version 4.0.6 and later) •

Internet Explorer 6, 7 and 8 •

Safari 3 •

Recommended hardware

Splunk is a high-performance application. If you are performing a comprehensive evaluation of Splunk for production deployment, we recommend that you use hardware typical of your production environment; this hardware should meet or exceed the recommended hardware capacity

specifications below.

For a discussion of hardware planning for deployment, check out the topic on capacity planning in this manual.

Note: Running Splunk in virtual machine (VM) mode on any platform will degrade performance.

Recommended and minimum hardware capacity

Platform Recommended hardware capacity/configuration Minimum supported hardware capacity

Non-Windows platforms

2x quad-core Xeon, 3GHz, 8GB RAM, RAID 0 or 1+0, with a 64 bit OS installed.

1x1.4 GHz CPU, 1 GB RAM

Windows platforms

2x quad-core Xeon, 3GHz, 8GB RAM, RAID 0 or 1+0, with a 64 bit OS installed.

Pentium 4 or equivalent at 2Ghz, 2GB RAM

All configurations other than Splunk light forwarder instances require at least the recommended hardware configuration.

The minimum supported hardware guidelines are designed for personal use of Splunk. •

(6)

Important: For all installations including forwarders, a minimum of 2GB hard disk space for your

Splunk installation is required in addition to the space required for your index. Refer to this topic on estimating your index size requirements in this manual for some planning information.

Hardware requirements for Splunk light forwarders

Recommended Dual Core 1.5Ghz+ processor, 1GB+ RAM

Minimum 1.0 Ghz processor, 512MB RAM

For more information on deployment planning, refer to the Deployment section of the Splunk community KnowledgeBase.

Supported file systems

Platform File systems

Linux ext2/3, reiser3, XFS, NFS 3/4 Solaris UFS, ZFS, VXFS, NFS 3/4 FreeBSD FFS, UFS, NFS 3/4 Mac OS X HFS, NFS 3/4 AIX JFS, JFS2, NFS 3/4 HP-UX VXFS, NFS 3/4 Windows NTFS, FAT32 Considerations regarding NFS

NFS is usually a poor choice for Splunk indexing activity, for reasons of performance, resilience, and semantics. In environments with very high bandwidth, very low latency links, that are kept highly reliable, it can be an appropriate choice. Typically, this is a NAS accessed via the NFS protocol.

Note: Several other file systems are supported. If you run Splunk on a filesystem that is not listed

above, Splunk may run a startup utility named locktest. Locktest is a program that tests the start up process. If locktest runs and fails, the filesystem is not suitable for running Splunk.

Note: On FreeBSD, mounting as nullfs is not supported.

Supported server hardware architectures

32 and 64-bit architectures are supported for some platforms. download page page for details.

Components of a Splunk deployment

Components of a Splunk deployment

Splunk is simple to deploy by design. By using a single software component and easy to understand configurations, Splunk can coexist with existing infrastructure or be deployed as a universal platform for accessing IT data.

(7)

The simplest deployment is the one you get by default when you install Splunk: indexing and searching on the same server. Data comes in from the sources you've configured, and you log into Splunk Web or the CLI on this same server to search, monitor, alert, and report on your IT data. Depending on your needs, you can also deploy components of Splunk on different servers to address your load and availability requirements. This section covers these potential components:

Indexer

In this mode, indexers, or index servers, provide indexing capability for local and remote data and host the primary Splunk datastore, as well as Splunk Web. Refer to "How indexing works" in the Admin Manual for more information.

Search head

In this mode, a Splunk instance is configured to direct user search requests to one or more indexers. Use distributed search to configure a search head to search across a pool of indexers.

Forwarder

Forwarders use the same Splunk software package but do not store indexed data locally. All indexed data is forwarded to remote index servers. To reduce operational footprint, Splunk Web is not used. Refer to the documentation on setting up a Splunk instance as a forwarder.

Deployment server

Both indexers and forwarders can also act as deployment servers. A deployment server distributes configuration information to running instances of Splunk via a push mechanism which is enabled through configuration. Refer to the documentation on setting up a Splunk instance as a deployment server.

Functions at a glance

Functions Indexer Search head Forwarder Deployment server Indexing x Web x Direct search x Forward to indexer x Deploy configurations x x x

Splunk's architecture and what gets installed

Splunk's architecture and what gets installed

This topic discusses Splunk's internal architecture and processes at a high level. If you're looking for information about third-party components used in Splunk, refer to the credits section in the Release notes.

(8)

Processes

A Splunk server runs two processes on your host, splunkd and splunkweb:

splunkd is a distributed C/C++ server that accesses, processes and indexes streaming IT data. It also handles search requests. splunkd processes and indexes your data by

streaming it through a series of pipelines, each made up of a series of processors.

Pipelines are single threads inside the splunkd process, each configured with a single

snippet of XML. ♦

Processors are individual, reusable C or C++ functions that act on the stream of IT

data passing through a pipeline. Pipelines can pass data to one another via queues.

splunkd supports a command line interface for searching and viewing results. ♦

splunkweb is a Python-based application server based on CherryPy that provides the Splunk Web user interface. It allows users to search and navigate IT data stored by Splunk servers and to manage your Splunk deployment through a Web interface.

splunkweb and splunkd can both communicate with your Web browser via REST:

splunkd also runs a Web server on port 8089 with SSL/HTTPS turned on by default. •

splunkweb runs a Web server on port 8000 without SSL/HTTPS by default. •

Architecture diagram

About Splunk licenses

About Splunk licenses

Each instance of Splunk must have its own license. This topic discusses the different Splunk

licenses, how to install or update a license, and what to do when you have a violation on your license.

Note: When running Splunk Enterprise, you must purchase a separate license for every instance of

(9)

Enterprise vs. Free license

Splunk provides two standard types of licenses, an Enterprise license, and a Free license.

When you download Splunk for the first time, you are asked to register. Your registration authorizes you to receive an Enterprise trial license, which allows a maximum indexing volume of 500 MB/day. The Enterprise trial license expires 60 days from download. If you are running with a Enterprise trial license and your license expires, Splunk continues to index your data. However, you will not be able to search until you install a new license.

Once you have installed Splunk, you can choose to run Splunk with the Enterprise trial license until it expires, purchase an Enterprise license, or switch to the Free license, which is included.

The Free license is not a trial license and does not have an expiration date. It also allows 500MB/day of indexing volume, but the following features that are available with the Enterprise license are

disabled:

Multiple user accounts and role-based access controls •

Distributed search •

Forwarding in TCP/HTTP formats (you can forward data to other Splunk instances, but not to non-Splunk instances)

Deployment management (including for clients) •

Scheduled saved searches (including summary indexing) and alerting/monitoring •

Learn more about Splunk with a Free license

Find more information about the different license features here. Also, read Splunk's Free license agreement.

Forwarding license

A license isn't required to enable forwarding, but enables security on the forwarder so that users must supply username and password to access it. Splunk includes a forwarder license that you can install on each Splunk forwarder. This 1 MB/day forward-only license is not subtracted from your existing license(s) and can be applied to multiple forwarders.

Each instance of Splunk that does any indexing must have its own license.

1. Stop Splunk: ./splunk stop

2. Copy $SPLUNK_HOME/etc/splunk-forwarder.license to

$SPLUNK_HOME/etc/splunk.license

3. Start Splunk: ./splunk start

(10)

Search head license

A search head does not normally index any data, but you don't want unrestricted access on there either. Apply a forwarder license to enable authentication on your search head instance.

Summary index searches count towards your indexed data volume. If you run these searches on your search head, it will violate the forwarder license and search functionality will be disabled. To avoid this, configure your summary index searches on your indexing instances instead.

Custom trial Enterprise license

You can request trial Enterprise licenses of varying size and duration. The default evaluation period is 60 days. If you are preparing a pilot for a large deployment and have requirements for a longer

duration or higher indexing volumes during your trial, contact Splunk Sales with your request.

Preview license

Splunk's Preview releases require a different license that is not compatible with other Splunk releases. Also, if you are evaluating a Preview release of Splunk, it will not run with a Free or Enterprise license. Preview licenses typically enable Enterprise features, they are just restricted to Preview releases. If you are evaluating a Preview version of Splunk, it will come with its own license.

View your license and usage details

You can view details about your license from Splunk Web or the command line interface (CLI). The details about your license include general information, such as the type of license, the indexing level, and the expiration date of the license.

View license information in Splunk Web

To view your license details in Splunk Web, go to Manager > License. Under "License & Usage". In addition to the general information about your license, the details include: the count of days until your license expires, the peak indexed amount (in MB), and the count of violations against your license.

Note: You can also install and update your license from this page.

You can also use search to learn information about indexing volumes. For a report on the daily indexed volume, use this search:

index=_internal todaysBytesIndexed LicenseManager-Audit NOT source=*web_service.log | eval Daily_Indexing_Volume_in_MBs =

todaysBytesIndexed/1024/1024 | timechart avg(Daily_Indexing_Volume_in_MBs) by host

Show license information in the CLI

If you have access to the CLI, you can view details about your license with: ./splunk show license

The CLI displays the same general details, but also includes information about the state of your license, such as the maximum number of violations (Max Violations) permitted by the license within

(11)

the grace period moving window (Violation Period). Splunk also displays an "Expiration State", which tells you when you license is either "7" days or "1" day from expiring; otherwise, it is "ok".

Install or update your license

All Splunk servers have a license located in $SPLUNK_HOME/etc/, whether it is a Free license

(splunk-free.license) or an Enterprise license (splunk.license). You can install and update your licenses with the CLI or from Splunk Web's Manager > License page.

Refer to the Admin Manual for instructions to install or update your Splunk license.

Migrating to 4.0

If you migrated a 3.x Splunk instance directly to 4.0, remove the

$SPLUNK_HOME/etc/splunk.license file before you run Splunk. The instance will then pick up the 60-day Enterprise trial license that is included with 4.0.

If you have a current Enterprise license/support contract for 3.x, an updated license is waiting for you. Log into splunk.com and go to http://www.splunk.com/store/myorders to pick it up. Replace your existing $SPLUNK_HOME/etc/splunk.license file with the new file, or use the instructions for updating your Splunk license.

Licenses for distributed deployments

If you have Splunk running on multiple hosts in a distributed environment, you must have a separate unique license key for each host. If you have been using a single license key for all your hosts, this will not work in versions 4.0 and later (except with an Enterprise Trial license, starting with version 4.0.3). Contact Splunk Support to have your license broken up into multiple keys for this purpose, or email Splunk Sales to purchase additional keys.

License violations

Violations occur when you exceed the maximum indexing volume allowed for your license. If you exceed your licensed daily volume on any one calendar day, you will get a violation warning. The message persists for 14 days. If you have 5 or more violations on an Enterprise license or 3

violations on a Free license in a rolling 30-day period, search will be disabled. Search

capabilities return when you have fewer than 5 (Enterprise) or 3 (Free) violations in the previous 30 days or when you apply a new license with a larger volume limit.

Note: During a license violation period, Splunk does not stop indexing your data. Splunk only blocks

access while you exceed your license.

Note: Searches to the _internal index are not disabled even during a licensing-enforcement period,

so you can still access the Indexing Status dashboard, or run searches against _internal to diagnose the licensing problem.

(12)

More about Splunk Free

More about Splunk Free

Splunk Free is a totally free (as in beer) version of Splunk. It allows you to index up to 500MB/day and will never expire. If you go over 500MB/day more than 3 times in a 30 day period, Splunk will continue to index your data, but search will be disabled until you are back down to 3 or fewer times in the 30 day period.

What's it for?

Splunk Free is designed for personal, ad-hoc search and visualization of IT data. You can use Splunk Free for ongoing indexing of small volumes (<500MB/day) of data. Additionally, you can use it for short-term bulk-loading and analysis of larger data sets--Splunk Free allows you to bulk-load much larger data sets up to 3 times within a 30 day period. This can be useful for forensic review of large data sets.

What is and isn't enabled

Splunk Free is a single-user product. All of Splunk's features are supported with the exception of: Multiple user accounts and role-based access controls (there's no authentication when using Splunk Free)

Distributed search •

Forwarding in TCP/HTTP formats (you can forward data to other Splunk instances, but not to non-Splunk instances)

Deployment management •

Scheduled saved searches (including summary indexing) and alerting/monitoring •

A Free instance can be used as a forwarder (to a Splunk indexer) but may not be a client of a deployment server.

Switching to Free from an Enterprise (Trial) License

When you first download and install Splunk, you are automatically using an Enterprise Trial license. You can continue to use the Enterprise Trial License until it expires, or switch to the Free license right away, depending on your requirements.

What you should know about switching to Free

Splunk Enterprise Trial gives you access to a number of features that are not available in Splunk Free. When you switch, be aware of the following:

User accounts or roles that you've created will no longer work. •

Anyone connecting to the instance will automatically be logged on as 'admin'. You will no longer see a login screen, though you will see the update check occur.

Any knowledge objects created by any user other than 'admin' (such as event type,

transaction, or source type definitions) and not already globally shared will not be available. If you need these knowledge objects to continue to be available after you switch to Splunk Free, you can either

(13)

use Manager to promote them to be globally available before you switch using the information in this topic or

hand edit the configuration files they are in to promote them as described here ♦

Scheduled searches you've set up (including alerts and summary indexing searches) will no longer fire/function.

you will no longer receive alerts from Splunk

searches and reports expecting summary indexes may be inaccurate, or return no results

dashboards that use search artifacts (such as via HiddenSavedSearch) will run the searches when you load them

♦ •

Configurations in outputs.conf to forward to third-party applications in TCP or HTTP formats will stop working.

When you attempt to make any of the above configurations in Manager while using an Enterprise Trial, you will be warned about the above limitations in a Free Splunk.

How do I switch to Splunk Free?

If you currently have Splunk Enterprise (trial or not), you can either wait for your Enterprise License to expire, or switch to a Free License at any time. To switch to a Free License:

1. Log in to Splunk Web as a user with admin privileges and navigate to Manager > License. 2. Review the text below the License and usage area, find the switch to a free license link, and

click it. A login page is displayed.

3. Select Switch to Free License and click Continue. 4. You are prompted to restart.

Before you install

Before you install

Before you install Splunk, be sure to review the system requirements and ensure that you've downloaded the right installation package for your system.

If you're upgrading from an earlier version of Splunk, review the information in "What to expect when upgrading to 4.0" before proceeding.

(14)

Step by step installation procedures

Choose your platform

Choose your platform

Choose from the list below for detailed installation procedures: Windows

Windows commandline instructions • Linux • Solaris • MacOS • FreeBSD • AIX • HP-UX •

Install on Windows

Install on Windows

This topic describes the procedure for installing on Windows using the GUI installer. More options are available for installation (such as silent installation) if you use the commandline installation.

Note: The Windows App was enabled by default in its app.conf file in versions 4.0-4.0.2. Starting in

version 4.0.3, it is disabled in this file by default. Read on for important details:

If you're upgrading from 4.0-4.0.2 to 4.0.3 or later, the Windows App will be disabled, even if it was enabled in the version you're upgrading from.

If you're doing a fresh installation of 4.0.3 or later, the Windows App is enabled by default via

the MSI and if you want to install it in a disabled state, you must specify this using the

SPLUNK_APP msiexec command as described in "Install on Windows via the commandline". •

Important: Running the 32-bit version of Splunk for Windows on a 64-bit platform is not

recommended. If you can run 64-bit Splunk on 64-bit hardware, we strongly recommend it. The performance is greatly improved over the 32-bit version.

Choosing the user Splunk should run as

When you run the Splunk Windows installer, you are given the option to select a user Splunk will run as.

If you install as the Local System user, Splunk will have access to all or nearly all of the important information on your local machine. However, the Local System user has no privileges on other Windows machines by design.

(15)

read Event Logs remotely •

collect performance counters remotely •

read network shares for log files •

enumerate the Active Directory schema using Active Directory monitoring •

The Domain account you use must also be a local Administrator or equivalent. Please ask your Windows Domain administrator for an account if you are unsure of what username to run Splunk under.

Minimum local permissions required for the two Splunk services:

Required user rights for the splunkd service:

Full control over Splunk's installation directory •

Read access to any flat-files •

Permission to log on as a service •

Permission to log on as a batch job •

Replace a process-level token •

Permission to act as part of the operating system •

Permission to bypass traverse checking •

Required user rights for the splunkweb service:

Full control over Splunk's installation directory •

Permission to log on as a service •

Note: These are the rights that splunkd and splunkweb specifically invoke. Other rights or

permissions may be required depending on your usage and what data you want to access.

Additionally, many user right assignments and other group policy restrictions can prevent Splunk from running. If you have issues, consider using a tool such as Sysinternals to troubleshoot your

environment, or reverting to running the splunkd service as an administrator or equivalent account.

Important: If you change the user Splunk runs as after you have installed, you must ensure that the

user you create has the necessary permissions, and also ensure that that user has Full Control permissions to the $SPLUNK_HOME/var directory.

If you accidentally specify the wrong user the first time you install

If you specified the wrong user during the installation procedure, you'll see two popup error dialogs telling you this. Complete the installation and then use these instructions to switch to the correct user. You must not start Splunk before doing this.

Install Splunk via the GUI installer

The Windows installer is an MSI file.

1. To start the installer, double-click the splunk.msi file.

(16)

2. To begin the installation, click Next.

Note: On each panel, you can click Next to continue, Back to go back a step, or Cancel to close the

installer.

The licensing panel is displayed.

3. Read the licensing agreement and select "I accept the terms in the license agreement". Click Next

to continue installing.

The Customer Information panel is displayed.

4. Enter the requested details and click Next.

The Destination Folder panel is displayed.

Note: Splunk is installed by default into the \Program Files\Splunk.

5. Click Change... to specify a different location to install Splunk, or click Next to accept the default

value.

The Logon Information panel is displayed.

Splunk installs and runs two Windows services, splunkd and splunkweb. These services will be installed and run as the user you specify on this panel. You can choose to run Splunk with Local System credentials, or provide a specific account. That account should have local administrator privileges, plus appropriate domain permissions if you are collecting data from other machines. The user Splunk runs as must have permissions to:

Run as a service. •

Read whatever files you are configuring it to monitor. •

Collect performance or other WMI data. •

Write to Splunk's directory. •

Note: If you install as the Local System user, some network resources may not be available to the

Splunk application. Additionally, WMI remote authentication will not work; this user has null

credentials and Windows servers normally disallow such connections. Only local data collection with WMI will be available. Contact your systems administrator for advice if you are unsure what user to specify.

6. Select a user type and click Next.

Important: When migrating or upgrading, you must re-specify the user you want Splunk to run

as--this information is not automatically maintained from release to release.

If you specified the local system user, proceed to step 8. Otherwise, the Logon Information: specify

(17)

7. Specify a username and password to install and run Splunk and click Next.

Note: To use an existing user, you can enter or browse for the username and domain details. Splunk

recommends using the Browse... button to ensure that you select a valid user. If you cannot browse for the user because that user doesn't exist in your security context, or you mistype the username, your installation will fail. Splunk cannot start without a valid username and password; browsing confirms the user is correct.

The pre-installation summary panel is displayed.

8. Click Install to proceed.

The installer runs and displays the Installation Complete panel.

Caution: If you specified the wrong user during the installation procedure, you will see two popup

error windows explaining this. If this occurs, Splunk installs itself as the local system user by default. Splunk will not start automatically in this situation. You can proceed through the final panel of the installation, leaving all boxes checked. Then, use these instructions to switch to the correct user before starting Splunk.

9. Check the boxes to Start Splunk and Start Splunk Web now. Click Finish.

The installation completes, Splunk starts, and Splunk Web launches in a supported browser.

Note: The first time you access Splunk Web after installation, login with the default username admin

and password changeme.

Launch Splunk in a Web browser

To access Splunk Web after you start Splunk on your machine, you can either: Click the Splunk icon in Start>Programs>Splunk

• or

Open a Web browser and navigate to http://localhost:8000.

Log in using the default credentials: username: admin and password: changeme . Be sure to change the admin password as soon as possible and make a note of what you changed it to.

Now that you've installed Splunk, what comes next?

Change the Splunk Web or splunkd service ports

If you want the Splunk Web service or the splunkd service to use a different port, you can change the defaults.

To change the splunk web service port: •

(18)

From the $SPLUNK_HOME/bin/ directory: splunk set web-port ####

To change the splunkd port: •

From the $SPLUNK_HOME/bin/ directory: splunk set splunkd-port ####

Note: If you specify a port and that port is not available, or if the default port is unavailable, Splunk

will automatically select the next available port.

Avoid IE Enhanced Security pop-ups

To avoid IE Enhanced Security pop-ups, add the following URLs to the allowed Intranet group or fully trusted group in IE:

quickdraw.splunk.com •

the URL of your Splunk instance •

Install or upgrade license

If you are performing a new installation of Splunk or switching from one license type to another, you must install or update your license.

Uninstall Splunk

To uninstall Splunk, use the Add or Remove Programs option in the Control Panel.

What's next?

Review this topic about considerations for deciding how to monitor Windows data in the Admin Manual.

Install on Windows via the commandline

Install on Windows via the commandline

This topic describes the procedures for installing Splunk on Windows using the commandline.

Important: Running the 32-bit version of Splunk for Windows on a 64-bit platform is not

recommended. If you can run 64-bit Splunk on 64-bit hardware, we strongly recommend it. The performance is greatly improved over the 32-bit version.

Note: The Windows App was enabled by default in its app.conf file in versions 4.0-4.0.2. Starting in

version 4.0.3, it is disabled in this file by default. Read on for important details:

If you're upgrading from 4.0-4.0.2 to 4.0.3 or later, the Windows App will be disabled, even if it was enabled in the version you're upgrading from.

If you're doing a fresh installation of 4.0.3 or later, the Windows App is enabled by default, unless you explicitly enable a different app such as SplunkLightFowarder. via the MSI.

However, you can enable the forwarder apps and enable Windows Event Log explicitly. If you want to install it in a disabled state, you must specify this using the SPLUNK_APP msiexec •

(19)

command as described later in this topic.

Choosing the user Splunk should run as

When you run the Splunk Windows installer, you are given the option to select a user Splunk will run as.

If you install as the Local System user, Splunk will have access to all or nearly all of the important information on your local machine. However, the Local System user has no privileges on other Windows machines by design. If you intend to read Event Logs or performance counters from other machines via WMI, or read network shares for log files, you will need a domain account. That account must be a local Administrator or equivalent, and should have rights to the external data you want to Splunk. Please ask your Windows domain administrator for an account if you are unsure of what credentials to give Splunk.

Minimum permissions required for the two Splunk services:

Required user rights for the splunkd service:

Full control over Splunk's installation directory •

Read access to any flat-files •

Permission to log on as a service •

Permission to log on as a batch job •

Replace a process-level token •

Permission to act as part of the operating system •

Permission to bypass traverse checking •

Required user rights for the splunkweb service:

Full control over Splunk's installation directory •

Permission to log on as a service •

Important: If you must change the user Splunk runs as after you have installed, you must ensure that

the user you create has the necessary permissions, and also ensure that that user has Full Control permissions to the $SPLUNK_HOME/var directory.

If you specified the wrong user during your installation, Splunk will not start. If this occurs, Splunk has installed itself as the local system user by default. Use the instructions in these instructions to switch to the correct user before starting Splunk.

How to use the MSI on the commandline

You can install Splunk for Windows using the MSI on the commandline by typing the following:

msiexec.exe /i Splunk.msi

This section lists the available flags for doing this, and provides a few examples of doing this in various configurations.

(20)

which Windows event logs to index or not •

which Windows registry hive to monitor •

which WMI information to pull •

the user Splunk runs as (be sure the user you specify has the appropriate permissions to access the content you want Splunk to index)

an included application configuration for Splunk to enable (such as the Splunk light forwarder) •

whether or not Splunk should start up automatically when the installation is completed •

Note: The first time you access Splunk Web after installation, log in with the default username admin

and password changeme.

Supported flags

The following is a list of the flags you can use when installing Splunk for Windows via the commandline.

Use this flag to specify directory to install. Default is c:\program files\splunk.

INSTALLDIR=<directory_path> •

Use these flags to specify alternate ports for splunkd and splunkweb to use

SPLUNKD_PORT=<port number> •

WEB_PORT=<port number> •

Use these flags to specify whether or not Splunk should index a particular Windows event log. WINEVENTLOGAPPCHECK=1/0, off by default

WINEVENTLOGSECCHECK=1/0, off by default •

WINEVENTLOGSYSCHECK=1/0, off by default •

WINEVENTLOGFWDCHECK=1/0, off by default •

WINEVENTLOGSETCHECK=1/0, off by default •

Use these flags to specify whether or not Splunk should index the Windows registry USER hive. By default these are set to 0 (off).

REGISTRYCHECK_U=1/0 •

REGISTRYCHECK_BASELINE_U=1/0 •

Use these flags to specify whether or not Splunk should index the Windows registry LocalMachine hive. By default, these are set to 0 (off).

REGISTRYCHECK_LM=1/0 •

REGISTRYCHECK_BASELINE_LM=1/0 •

Use these flags to specify which WMI performance information to index. These are set to 0 (off) by default.

WMICHECK_CPUTIME=1/0 •

(21)

WMICHECK_LOCALDISK=1/0 • WMICHECK_FREEDISK=1/0 • WMICHECK_MEMORY=1/0 •

Use this flag to specify a user Splunk should run as. Supported values are: 1 for the LocalSystem user and 2 for a different user. The default value is 1.

RBG_LOGON_INFO_USER_CONTEXT=1/2 •

Use these flags to provide domain/username and password information for the user specified in RBG_LOGON_INFO_USER_CONTEXT. You must specify the domain with the username in the format "domain\username".

IS_NET_API_LOGON_USERNAME="<domain\username>" •

IS_NET_API_LOGON_PASSWORD="<pass>" •

Use this flag to specify an included Splunk application configuration to enable for this installation of Splunk. Currently supported options for <SplunkApp> are: SplunkLightForwarder, SplunkForwarder. Refer to the documentation about the Splunk forwarder and light forwarder configurations for more information about the forwarders. If you specify either the Splunk forwarder or light forwarder here, you must also specify FORWARD_SERVER="<server:port>".

SPLUNK_APP=<SplunkApp> •

To install Splunk with no applications at all, specify this flag but leave the value empty (

SPLUNK_APP="" ).

Use this flag *only* when you are also using SPLUNK_APP to enable either the Splunk forwarder or light forwarder. Specify the server and port of the Splunk server to which this forwarder will send data.

FORWARD_SERVER="<server:port>" •

Use this flag to specify whether or not Splunk should start up automatically when the installation completes. The default value is 1 (on).

LAUNCHSPLUNK=0/1 •

Important: If you are enabling an App (SPLUNK_APP), Splunk will start automatically; this cannot be

overridden.

Use these flags to specify which Splunk services start up automatically at boot time. AUTOSTARTSERVICE=0/1 (starts both services)

AUTOSTARTSERVICE_SPLUNKD=0/1 •

AUTOSTARTSERVICE_SPLUNKWEB=0/1 •

(22)

Silent installation

To run the installation silently, add /quiet to the end of your installation command string. If your

system is running UAC (which is sometimes on by default) you must run the installation as

Administrator. To do this: when opening a cmd prompt, right click and select "Run As Administrator". Then use this cmd window to run the silent install command.

Examples

The following are some examples of using different flags.

Install Splunk to run as the Local System user

msiexec.exe /i Splunk.msi RBG_LOGON_INFO_USER_CONTEXT=1

Specify the username and the domain the user belongs to

msiexec.exe /i Splunk.msi SPLUNK_APP="SplunkForwarder"

RBG_LOGON_INFO_USER_CONTEXT=2 IS_NET_API_LOGON_USERNAME="AD\splunk" IS_NET_API_LOGON_PASSWORD="splunk123"

Enable SplunkForwarder, disable indexing of the Windows System event log, and run the installer in silent mode

msiexec.exe /i Splunk.msi SPLUNK_APP="SplunkForwarder"

FORWARD_SERVER="<server:port>" WINEVENTLOGSYSCHECK=0 /quiet

Where "<server:port>" are the server and port of the Splunk server to which this machine should

send data.

Launch Splunk in a Web browser

To access Splunk Web after you start Splunk on your machine, you can either: Click the Splunk icon in Start>Programs>Splunk

• or

Open a Web browser and navigate to http://localhost:8000.

Log in using the default credentials: username: admin and password: changeme . Be sure to change the admin password as soon as possible and make a note of what you changed it to.

Now that you're ready to use Splunk, refer to the User Manual and begin using Splunk!

Avoid IE Enhanced Security pop-ups

To avoid IE Enhanced Security pop-ups, add the following URLs to the allowed Intranet group or fully trusted group in IE:

quickdraw.splunk.com •

the URL of your Splunk instance •

(23)

Install or upgrade license

If you are performing a new installation of Splunk or switching from one license type to another, you must install or update your license.

Uninstall Splunk

To uninstall Splunk, use the Add or Remove Programs option in the Control Panel. You can also use msiexec from the commandline.

Install on Linux

Install on Linux

You can install Splunk on Linux using RPM or DEB packages, or a tarball.

RedHat RPM install

To install the Splunk RPM in the default directory /opt/splunk:

rpm -i splunk_package_name.rpm

To install Splunk in a different directory, use the --prefix flag:

rpm -i --prefix=/opt/new_directory splunk_package_name.rpm To upgrade an existing Splunk installation using the RPM:

rpm -U splunk_package_name.rpm

To upgrade an existing Splunk installation that was done in a different directory, use the --prefix

flag:

rpm -U --prefix=/opt/new_directory splunk_package_name.rpm

If you want to automate your RPM install with kickstart, add the following to your kickstart file: ./splunk start --accept-license

./splunk enable boot-start

Note: The second line is optional for the kickstart file.

Debian DEB install

To install the Splunk DEB package: dpkg -i splunk_package_name.deb

(24)

Tarball install

To install Splunk on a Linux system, expand the tarball into an appropriate directory. The default install directory is /opt/splunk.

When installing with the tarball:

Splunk does not create the splunk user automatically. If you want Splunk to run as a specific

user, you must create the user manually. •

Be sure the disk partition has enough space to hold the uncompressed volume of the data you plan to keep indexed.

What gets installed

Splunk package status: dpkg --status splunk List all packages: dpkg --list

Start Splunk

Splunk can run as any user on the local system. If you run Splunk as a non-root user, make sure that Splunk has the appropriate permissions to read the inputs that you specify. Refer to the instructions for running Splunk as a non-root user for more information.

To start Splunk from the command line interface, run the following command from

$SPLUNK_HOME/bin directory (where $SPLUNK_HOME is the directory into which you installed

Splunk):

./splunk start

By convention, this document uses:

$SPLUNK_HOME to identify the path to your Splunk installation. •

$SPLUNK_HOME/bin/ to indicate the location of the command line interface.

Startup options

The first time you start Splunk after a new installation, you must accept the license agreement. To start Splunk and accept the license in one step:

$SPLUNK_HOME/bin/splunk start --accept-license

(25)

Launch Splunk Web and log in

After you start Splunk and accept the license agreement,

1. In a browser window, access Splunk Web at http://<hostname>:port.

hostname is the host machine. •

port is the port you specified during the installation (the default port is 8000).

2. Splunk Web prompts you for login information (default, username admin and password

changeme) before it launches. If you switch to Splunk Free, you will bypass this logon page in future

sessions.

Now that you've installed Splunk, what comes next?

Uninstall Splunk

Use your local package management commands to uninstall Splunk. In most cases, files that were not originally installed by the package will be retained. These files include your configuration and index files which are under your installation directory.

If you can't use package management commands, follow the instructions for manually uninstalling Splunk components.

RedHat Linux

To uninstall from RedHat Linux rpm -e splunk_product_name

Debian Linux

To uninstall from Debian Linux: dpkg -r splunk

To purge (delete everything, including configuration files): dpkg -P splunk

Install on Solaris

Install on Solaris

This topic provides the procedures for installing Splunk on Solaris.

Install Splunk

(26)

PKG file install

The PKG installation package includes a request file that prompts you to answer a few questions before Splunk installs.

pkgadd -d ./splunk_product_name.pkg A list of the available packages is displayed.

Select the packages you wish to process (the default is "all"). •

The installer then prompts you to specify a base installation directory. To install into the default directory, /opt/splunk, leave this blank.

PKG file upgrade

To upgrade an existing Splunk installation using a PKG file, use the same command line as you would for a fresh install.

pkgadd -d ./splunk_product_name.pkg

You will be prompted to overwrite any changed files, answer yes to every one.

To run the upgrade silently (and not have to answer yes for every file overwrite), type: pkgadd -n -d ./splunk_product_name.pkg

Tarball install

To install Splunk on a Solaris system, expand the tarball into an appropriate directory. By default, Splunk installs into /opt/splunk/.

When installing with the tarball:

Splunk does not create the splunk user automatically. If you want Splunk to run as a specific

user, you must create the user manually. •

Be sure the disk partition has enough space to hold the uncompressed volume of the data you plan to keep indexed.

What gets installed

Splunk package info: pkginfo -l splunk List all packages: pkginfo

(27)

Start Splunk

Splunk can run as any user on the local system. If you run Splunk as a non-root user, make sure that Splunk has the appropriate permissions to read the inputs that you specify. For more information, refer to the instructions on running Splunk as a non-root user.

To start Splunk from the command line interface, run the following command from

$SPLUNK_HOME/bin directory (where $SPLUNK_HOME is the directory into which you installed

Splunk):

./splunk start

By convention, Splunk's documentation uses:

$SPLUNK_HOME to identify the path to your Splunk installation. •

$SPLUNK_HOME/bin/ to indicate the location of the command line interface.

Startup options

The first time you start Splunk after a new installation, you must accept the license agreement. To start Splunk and accept the license in one step:

$SPLUNK_HOME/bin/splunk start --accept-license

Note: There are two dashes before the accept-license option.

Launch Splunk Web and log in

After you start Splunk and accept the license agreement,

1. In a browser window, access Splunk Web at http://mysplunkhost:port, where:

mysplunkhost is the host machine. •

port is the port you specified during the installation (8000).

2. Splunk Web prompts you for login information (default, username admin and password

changeme) before it launches. If you switch to Splunk Free, you will bypass this logon page in future sessions.

Now that you've installed Splunk, what comes next?

Uninstall Splunk

Use your local package management commands to uninstall Splunk. In most cases, files that were not originally installed by the package are retained. These files include your configuration and index files which are under your installation directory.

(28)

Install on Mac OS

Install on Mac OS

The Mac OS build comes in two forms: a DMG package and a tarball. Below are instructions for the: Graphical (basic) and command line installs using the DMG file.

Tarball install. •

Graphical install

1. Double-click on the DMG file.

A Finder window containing splunk.pkg opens.

2. In the FInder window, double-click on splunk.pkg.

The Splunk installer opens and displays the Introduction, which lists version and copyright information.

3. Click Continue.

The Select a Destination window opens.

4. Choose a location to install Splunk.

To install in the default directory, /Applications/splunk, click on the harddrive icon. •

To select a different location, click Choose Folder...

5. Click Continue.

The pre-installation summary displays. If you need to make changes, Click Change Install Location to choose a new folder, or

Click Back to go back a step.

6. Click Install.

Your installation will begin. It may take a few minutes.

7. When your install completes, click Finish.

Command line install

1. To mount the dmg:

hdid splunk_package_name.dmg

(29)

To the root volume: •

installer -pkg splunk.pkg -target / To a different disk of partition: •

installer -pkg splunk.pkg -target /Volumes\ Disk

-target specifies a target volume, such as another disk, where Splunk will be installed in /Applications/splunk.

To install into a directory other than /Applications/splunk on any volume, use the graphical

installer as described above.

Tarball install

To install Splunk on a Mac OS, expand the tarball into an appropriate directory. The default install directory is /Applications/splunk.

When installing with the tarball:

Splunk does not create the splunk user automatically. If you want Splunk to run as a specific user, you must create the user manually.

Be sure the disk partition has enough space to hold the uncompressed volume of the data you plan to keep indexed.

Start Splunk

Splunk can run as any user on the local system. If you run Splunk as a non-root user, make sure that Splunk has the appropriate permissions to read the inputs that you specify.

To start Splunk from the command line interface, run the following command from

$SPLUNK_HOME/bin directory (where $SPLUNK_HOME is the directory into which you installed Splunk):

./splunk start

By convention, this document uses:

$SPLUNK_HOME to identify the path to your Splunk installation.

$SPLUNK_HOME/bin/ to indicate the location of the command line interface. •

Startup options

The first time you start Splunk after a new installation, you must accept the license agreement. To start Splunk and accept the license in one step:

$SPLUNK_HOME/bin/splunk start --accept-license

(30)

Launch Splunk Web and log in

After you start Splunk and accept the license agreement,

1. In a browser window, access Splunk Web at http://<hostname>:port.

hostname is the host machine. •

port is the port you specified during the installation (the default port is 8000).

2. Splunk Web prompts you for login information (default, username admin and password

changeme) before it launches. If you switch to Splunk Free, you will bypass this logon page in future

sessions.

Now that you've installed Splunk, what comes next?

Manage your license

If you are performing a new installation of Splunk or switching from one license type to another, you must install or update your license.

Uninstall Splunk

Use your local package management commands to uninstall Splunk. In most cases, files that were not originally installed by the package will be retained. These files include your configuration and index files which are under your installation directory.

You can also simply go to $SPLUNK_HOME/bin, type ./splunk stop on the commandline and then delete the $SPLUNK_HOME directory and everything under it.

Install on FreeBSD

Install on FreeBSD

The FreeBSD builds comes in two forms: an installer (5.4-intel) and a tarball (i386). Both are TGZ files.

Basic install

To install FreeBSD using the intel installer: pkg_add splunk_package_name-5.4-intel.tgz

This installs Splunk in the default directory, /opt/splunk/

To install Splunk in a different directory:

(31)

Tarball install

To install Splunk on a FreeBSD system, expand the tarball into an appropriate directory. The default install directory is /opt/splunk.

When installing with the tarball:

Splunk does not create the splunk user automatically. If you want Splunk to run as a specific

user, you must create the user manually. •

Be sure the disk partition has enough space to hold the uncompressed volume of the data you plan to keep indexed.

After you install

To ensure that Splunk functions properly on FreeBSD, you must:

1. Add the following to /boot/loader.conf

kern.maxdsiz="2147483648" # 2GB kern.dfldsiz="2147483648" # 2GB machdep.hlt_cpus=0

2. Add the following to /etc/sysctl.conf:

vm.max_proc_mmap=2147483647

A restart of the OS is required for the changes to effect.

What gets installed

To see the list of Splunk packages: pkg_info -L splunk

To list all packages: pkg_info

Start Splunk

Splunk can run as any user on the local system. If you run Splunk as a non-root user, make sure that Splunk has the appropriate permissions to read the inputs that you specify.

To start Splunk from the command line interface, run the following command from

$SPLUNK_HOME/bin directory (where $SPLUNK_HOME is the directory into which you installed

Splunk):

./splunk start

(32)

$SPLUNK_HOME to identify the path to your Splunk installation. •

$SPLUNK_HOME/bin/ to indicate the location of the command line interface.

Startup options

The first time you start Splunk after a new installation, you must accept the license agreement. To start Splunk and accept the license in one step:

$SPLUNK_HOME/bin/splunk start --accept-license

Note: There are two dashes before the accept-license option.

Launch Splunk Web and log in

After you start Splunk and accept the license agreement,

1. In a browser window, access Splunk Web at http://<hostname>:port.

hostname is the host machine. •

port is the port you specified during the installation (the default port is 8000).

2. Splunk Web prompts you for login information (default, username admin and password

changeme) before it launches. If you switch to Splunk Free, you will bypass this logon page in future

sessions.

Now that you've installed Splunk, what comes next?

Manage your license

If you are performing a new installation of Splunk or switching from one license type to another, you must install or update your license.

Uninstall Splunk

Use your local package management commands to uninstall Splunk. In most cases, files that were not originally installed by the package will be retained. These files include your configuration and index files which are under your installation directory.

To uninstall Splunk from the default location: pkg_delete splunk

To uninstall Splunk from a different location: pkg_delete -p /usr/splunk splunk

(33)

Install on AIX

This topic will guide you through installing Splunk on the AIX platform.

Note: If you are upgrading, review the upgrade documentation later in this manual and check the

migration documentation for any migation considerations before proceeding.

Install Splunk

The AIX install comes in tarball form. When installing with the tarball:

Splunk does not create the splunk user automatically. If you want Splunk to run as a specific

user, you must create the user manually. •

Be sure the disk partition has enough space to hold the uncompressed volume of the data you plan to keep indexed.

To install Splunk on an AIX system, expand the tarball into an appropriate directory. The default install directory is /opt/splunk.

For AIX 5.3, check to make sure your service packs are up to date. Splunk requires the following service level:

$ oslevel -r 5300-005

Start Splunk

Splunk can run as any user on the local system. If you run Splunk as a non-root user, make sure that Splunk has the appropriate permissions to read the inputs that you specify. Refer to the instructions for running Splunk as a non-root user for more information.

To start Splunk from the command line interface, run the following command from

$SPLUNK_HOME/bin directory (where $SPLUNK_HOME is the directory into which you installed

Splunk):

./splunk start

By convention, this document uses:

$SPLUNK_HOME to identify the path to your Splunk installation. •

$SPLUNK_HOME/bin/ to indicate the location of the command line interface.

Note: The AIX version of Splunk does not register itself to auto-start on reboot.

Startup options

The first time you start Splunk after a new installation, you must accept the license agreement. To start Splunk and accept the license in one step:

(34)

$SPLUNK_HOME/bin/splunk start --accept-license

Note: There are two dashes before the accept-license option.

For more information, refer to "Splunk startup options" in this manual.

Launch Splunk Web and log in

After you start Splunk and accept the license agreement,

1. In a browser window, access Splunk Web at http://<hostname>:port.

hostname is the host machine. •

port is the port you specified during the installation (the default port is 8000).

2. Splunk Web prompts you for login information (default, username admin and password

changeme) before it launches. If you switch to Splunk Free, you will bypass this logon page in future

sessions.

Now that you've installed Splunk, what comes next?

Manage your license

If you are performing a new installation of Splunk or switching from one license type to another, you must update your license.

Uninstall Splunk

Use your local package management commands to uninstall Splunk. In most cases, files that were not originally installed by the package will be retained. These files include your configuration and index files which are under your installation directory.

Install on HP-UX

Install on HP-UX

To install Splunk on an HP-UX system, expand the tarball into an appropriate directory. The default install directory is /opt/splunk.

When installing with the tarball:

Splunk does not create the splunk user automatically. If you want Splunk to run as a specific user, you must create the user manually.

Be sure the disk partition has enough space to hold the uncompressed volume of the data you plan to keep indexed.

Start Splunk

Splunk can run as any user on the local system. If you run Splunk as a non-root user, make sure that Splunk has the appropriate permissions to read the inputs that you specify.

(35)

To start Splunk from the command line interface, run the following command from

$SPLUNK_HOME/bin directory (where $SPLUNK_HOME is the directory into which you installed

Splunk):

./splunk start

By convention, this document uses:

$SPLUNK_HOME to identify the path to your Splunk installation. •

$SPLUNK_HOME/bin/ to indicate the location of the command line interface. •

Note: The HP-UX version of Splunk does not register itself to auto-start on reboot.

Startup options

The first time you start Splunk after a new installation, you must accept the license agreement. To start Splunk and accept the license in one step:

$SPLUNK_HOME/bin/splunk start --accept-license

Note: There are two dashes before the accept-license option.

Launch Splunk Web and log in

After you start Splunk and accept the license agreement,

1. In a browser window, access Splunk Web at http://<hostname>:port.

hostname is the host machine.

port is the port you specified during the installation (the default port is 8000). •

2. Splunk Web prompts you for login information (default, username admin and password

changeme) before it launches. If you switch to Splunk Free, you will bypass this logon page in future sessions.

Now that you've installed Splunk, what comes next?

Manage your license

If you are performing a new installation of Splunk or switching from one license type to another, you must install or update your license.

Install a license

Install a license

Each instance of Splunk server must have its own license. This topic discusses how to install or update a license, and what to do when you have a violation on your license.

(36)

For more details about license types and policies, refer to "About Splunk licenses" earlier in this manual.

Note: You must purchase a separate license for every instance of Splunk with an Enterprise license

that you deploy.

Install your license

All Splunk servers have a license located in $SPLUNK_HOME/etc/, whether it is a Free license (splunk-free.license) or an Enterprise license (splunk.license). You can install and update your licenses with the CLI or using Splunk Web.

Install a license using Splunk Web

1. Log into Splunk Web as the admin user. 2. Click Manager>License.

3. Click Change License.

4. Paste in your license key and click Save.

5. Return to the main Manager tab and click Restart Splunk.

Note - Sometimes, you may get an 'Invalid License' error when you apply a license via Splunk Web.

This is usually caused by hidden characters getting picked up and added to the license string when using copy&paste. To resolve this, you can update the new splunk.license file manually in $SPLUNK_HOME/etc. Make sure you use a plain text editor to do this.

Pre-seeding your license before first time run

Starting with 4.0.2, by default when you start Splunk for the first time, it moves aside any existing 3.x license and replaces it with a temporary Enterprise trial license. This allows you to bring up the new version of Splunk without having your license be expired until you get your new one copied in.

If you are migrating to Splunk 4.0.2 or later and have a valid 4.x license, you can pre-seed the license file so that it pulls in and installs your new license the first time you start Splunk 4. This is useful if you have to deploy multiple instances and don't want to have to manually copy the new license in after starting Splunk on each machine.

Migrate to 4.0.2 or later, but don't start Splunk yet. •

Copy your new license into $SPLUNK_HOME/etc/splunk-user.license. •

Start Splunk. •

If you're making a deployable package, you can include the splunk-user.license file with your updated license in it before you tar/zip it up for deployment to other systems.

(37)

License violations

Violations occur when you exceed the maximum indexing volume allowed for your license. If you exceed your licensed daily volume on any one calendar day, you will get a violation warning. The message persists for 14 days. If you have more than 5 violations in a rolling 30-day period, search will be disabled. Search capabilities return when you have fewer than 5 violations in the previous 30 days or when you apply a new license with a larger volume limit.

Got license violations? Click here to troubleshoot

Note: During a license violation period, Splunk does not stop indexing your data. Splunk only

(38)

Start Splunk for the first time

Start Splunk for the first time

Start Splunk for the first time

To start Splunk:

On Windows You can start Splunk on Windows using either the commandline, or the Windows

Services Manager. Using the commandline offers more options, described later in this section. In a

cmd window, go to C:\Program Files\Splunk\bin and type: splunk start

(For Windows users: in the subsequent examples and information, replace $SPLUNK_HOME with C:\Program Files\ if you have installed Splunk in the default location.)

On UNIX Use the Splunk command line interface (CLI):

$SPLUNK_HOME/bin/splunk start

Splunk then displays the license agreement and prompts you to accept the before the startup sequence continues.

Other start options

To automatically accept the license when you start Splunk for the first time, add the

accept-license option to the start command: $SPLUNK_HOME/bin/splunk start --accept-license The startup sequence displays:

Checking prerequisites...

Checking http port [8000]: open Checking mgmt port [8089]: open

Verifying configuration. This may take a while... Finished verifying configuration.

Checking index directory... Verifying databases...

Verified databases: _audit, _blocksignature, _internal, _thefishbucket, history, main, sampledata, splunklogger, summary Checking index files

All index checks passed.

All preliminary checks passed. Starting splunkd...

Starting splunkweb... Splunk Server started.

The Splunk web interface is at http://<hostname>:8000

If you get stuck, we're here to help. Feel free to email us at '[email protected]'.

Note: If the default ports are already in use (or are otherwise not available), Splunk will offer to use

(39)

There are two other start options: no-prompt and answer-yes:

If you run $SPLUNK_HOME/bin/splunk start --no-prompt, Splunk proceeds with startup until it requires you to answer a question. Then, it displays the question, why it is quitting, and quits.

If you run SPLUNK_HOME/bin/splunk start --answer-yes, Splunk proceeds with startup and automatically answers "yes" to all yes/no questions. Splunk displays the question and answer as it continues.

If you run start with all three options in one line, for example:

$SPLUNK_HOME/bin/splunk start --answer-yes --no-prompt --accept-license Splunk does not ask you to accept the license.

Splunk answers yes to any yes/no question. •

Splunk quits when it encounters a non-yes/no question. •

Start and disable individual processes

You can start and stop individual Splunk processes by adding the process as an object to the start

command. The objects include:

splunkd, the Splunk server daemon. •

splunkweb, Splunk's Web interface process.

For example, to start only splunkd:

$SPLUNK_HOME/bin/splunk start splunkd To disable splunkweb:

$SPLUNK_HOME/bin/splunk disable webserver

For more information about start, refer to the CLI help page:

$SPLUNK_HOME/bin/splunk help start

Launch Splunk Web

Navigate to:

http://mysplunkhost:8000

Use whatever host and port you chose during installation.

The first time you log in to Splunk Enterprise, the default login details are:

Username - admin. Password - changeme.

References

Related documents

One possible reason for this behaviour could be that reaching the maximum/minimum limits may be the best way to ensure stable output for the other gen- erators, as these limits

The Pima County Sheriff’s Department aims to reduce the number of traffic collision injuries and fatalities by conducting additional DUI and speed enforcement, utilizing equipment

Splunk, Splunk&gt;, Listen to Your Data, The Engine for Machine Data, Splunk Cloud, Splunk Light and SPL are trademarks and regi stered trademarks of Splunk Inc.. in the United

Scheduling of Two Parallel Machines with Linear Decreasing Time Slot Costs to Minimize Total Weighted Completion Time ⋆ Alexander Kononov1,2 and Irina Lushchakova3,4 1..

Along with place identifications, we use the distinction between the civic and cultural components of identity as well as intersectionality to capture how the young people we

Splunk can automate the auditing of data integrity, availability and confidentiality across the enterprise to ensure compliance with security policies. Splunk can automate

Obligations with digital agency software offers unlimited invoicing and narrow down late payments directly on invoices compliant with dedicated staff through the use

It is important to note that in most previous works on adaptive networks a closed set of macroscopic equations is obtained by assuming that links in the network are drawn at random